passer de gambas 3.15.2 à 14

Soumis par paulageron le lun 25/01/2021 - 18:05

passer de gambas 3.15.2 à 14
j'aimerai passer de gambas 3.15.2 à gambas 3.14 apparemment j'aurai bien moins de bugs sur laurux
est ce réalisable sans trop de soucis ?
qu'en pensez vous ?

paulageron

mar 26/01/2021 - 14:13

exemple quand je vais faire un devis j'ouvre la section saisir une facture >devis> si je clique sur une ligne d'un devis déjà fais alors j'ai une fenêtre qui s'ouvre
"this application has raised an unexpected error and must abort.
no mouse event data
Facture.colbl_Click.1871
close ignore"
la semaine dernière c'était un bug sur la saisie des comptes collectifs.
J'ai cherché une solution pour que techniquement Laurux tourne sans problème mais j'ai peur de me lancer car je vais pas pouvoir passer mes soirées à résoudre des bugs. J'ai cherché une solution d'aide technique même payante et j'ai trouvé une boite Altahe informatique qui pourrait faire ça et c'est eux qui m'ont dit que gambas 3.14 règlerai le problème.

on a le meme pbl avec la 3.15
impossible d'installer la 3.14 on a des messages d'erreurs pendant la procédure make install
Y a t'il une solution pour installer la 3.14

paulageron

mar 26/01/2021 - 16:51

alors j'ai fais :
facon-piscine@facon-piscine:~$ sudo apt-get remove gambas*
[sudo] Mot de passe de facon-piscine :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet gambas-3.14.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « gambas-3.14.0 »
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « gambas-3.14.0 »
facon-piscine@facon-piscine:~$
Il y a un problème je crois j'ai fais toutes les commandes et il me dit que Gambas 3.15.2 est la version la plus récente donc ça n'a pas marché

paulageron

mar 26/01/2021 - 16:57

ok alors je récapitule
sudo apt-get remove gambas*
sudo rm -f /etc/apt/sources.list.d/gambas-team-ubuntu-gambas3*
sudo apt update
sudo apt install gambas3 gambas3-gb-sdl-sound gambas3-gb-form-print

ce qui donne :
facon-piscine@facon-piscine:~$ sudo apt install gambas3 gambas3-gb-sdl-sound gambas3-gb-form-print
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
gambas3 est déjà la version la plus récente (3.15.2+git6080.2c36245e4+build5.da1e7df.17.76493e1~ubuntu20.04.1).
gambas3-gb-form-print est déjà la version la plus récente (3.15.2+git6080.2c36245e4+build5.da1e7df.17.76493e1~ubuntu20.04.1).
gambas3-gb-sdl-sound est déjà la version la plus récente (3.15.2+git6080.2c36245e4+build5.da1e7df.17.76493e1~ubuntu20.04.1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 72 non mis à jour.
facon-piscine@facon-piscine:~$

Pour Alain un exemple de compilation ici : https://www.laurux.fr/node/490
Avec le lien pour avoir les infos récentes
Si vous êtes sur la dernière version de mint la solution proposée sur ce post fonctionne.
Paulageron est ce que le ppa de gambas est toujours actif ?
J'en profite pour une petite remarque, il serait mieux d'avoir un fil de discutions par thème voir par personne, avec un titre le plus explicite possible dans la bonne section du forum et sur le 1° post une description comprenant : Version de Laurux + version de gambas + nom et version du système.
Merci

paulageron

sam 30/01/2021 - 14:09

J'ai refais la manipe suivante :
sudo apt-get remove gambas3
sudo rm -f /etc/apt/sources.list.d/gambas-team-ubuntu-gambas3*
sudo apt update
sudo apt install gambas3 gambas3-gb-sdl-sound gambas3-gb-form-print

Voici le retour de la dernière manipe :

facon-piscine@facon-piscine:~$ sudo apt install gambas3 gambas3-gb-sdl-sound gambas3-gb-form-print
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
gambas3-gb-form-print est déjà la version la plus récente (3.15.2+git6080.2c36245e4+build5.da1e7df.17.76493e1~ubuntu20.04.1).
gambas3-gb-sdl-sound est déjà la version la plus récente (3.15.2+git6080.2c36245e4+build5.da1e7df.17.76493e1~ubuntu20.04.1).
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
gambas3 : Dépend: gambas3-gb-jit (>= 3.14.3-2ubuntu3.1) mais ne sera pas installé
Dépend: gambas3-ide (>= 3.14.3-2ubuntu3.1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

C'est que vous n'avez pas supprimé gambas ... on va faire différemment :
- Vous allez exécuter : "logiciel et mise à jour" dans l'onglet "Autres logiciels" vous allez décocher le ppa gambas-team.
- Vous ouvrez la logithèque ubuntu et vous cherchez synaptic package manager, si il n'est pas installé vous l'installez.
- vous lancez synaptic, vous cliquez sur recherche, vous entrez "gambas"
Vous sélectionnez le 1°=> vous allez au dernier puis shift+clique sur le dernier va vous sélectionner l'ensemble des gambas
clique droit => Sélectionner pour suppression
Cliquez sur Appliquer
Si certains ne se désinstalles pas correctement il faudra le faire un à un dans l'ordre que vous indiquera le programme
Puis vous ouvrez un terminal :
sudo apt install gambas3 gambas3-gb-sdl-sound gambas3-gb-form-print